Previous in Forum: Neutral   Next in Forum: Generator
Close
Close
Close
Power-User

Join Date: Oct 2008
Location: Jakarta Indonesia
Posts: 123
Good Answers: 7

Broyce ELR "Test Button" No Trip

03/23/2012 10:22 PM

Hi everybody,

We use tens of Broyce ELAM44V-30 Earth Leakage Relays in MCCs we supplied to the plant owner.

I tested all relays to confirm the tripping function by injecting current in the ZCT, and I confirmed all relays trip.

LED lamp indications were all correct.

However, some relays "TEST" button do not work. I tried to find what is wrong in connection, only to find all circuits are OK.

I exchanged the problem ones with new ELR units, however, the problem persisted. So, I guess relays were OK, but there were some wiring problems.

Until today I have not found any wiring errors.

If you same experience with Broyce ELR, please let me know the how did you fixed this issue.

The problem is only "TEST" button. Other functions are correct.

Regards.

__________________
Akihito Shigeno @ JGC-Indonesia
Register to Reply
Interested in this topic? By joining CR4 you can "subscribe" to
this discussion and receive notification when new comments are added.
Guru
United Kingdom - Member - New Member

Join Date: Aug 2010
Location: Resting under the Major Oak
Posts: 4348
Good Answers: 180
#1

Re: Broyce ELR "test button" no trip

03/23/2012 11:41 PM

Have a look at http://www.broycecontrol.com/PDF/Earth%20Leakage%20Relays%20ELRM44V30-2-A.pdf it give a phone number you can call.

It helps if you give the correct model number.

__________________
The reports of my death are greatly exaggerated.
Register to Reply
Register to Reply
Interested in this topic? By joining CR4 you can "subscribe" to
this discussion and receive notification when new comments are added.

Previous in Forum: Neutral   Next in Forum: Generator

Advertisement